• 0
ptoaster

Trouble downloading the game

Question

I played limitro a while ago and am trying to download it on a new computer. I downloaded and unzipped the files, launched to .exe which seemed to work except to "Play" button is grayed out. From there I've also tried to open the application directly which works up until the point where it fails to connect and displays a message saying "failed to connect to server". I'm confident my username and password are correct and I've tried redownloading the files as well as deleting the limitro.dat and rerunning the .exe, but regardless the play button comes up gray and it doesn't connect to the server. Any help would be appreciated.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now